Gt40 tubular - just loud?

For anything machine shop / speed shop or engine specific. More technical than the range but not quite tuning specific.
Landho
Posts: 14
Joined: 27 Feb 2021, 16:19
Location: Austin, TX USA
Vehicle Information: 1969 Ford Bronco
347 Stroker, Dart Heads, CBAZA

Gt40 tubular - just loud?

Unread post by Landho »

I can’t seem to get to Stangnet anymore ... and don’t see much about it on corral. Switched from explorer upper to gt40 tubular - for no reason other than it came with the replacement lower I got and it’s sexy, I’m not out flowing either so both are the same and the tubular is sexy (that’s worth 18hp at least) - BUT:

It’s just loud - the tubular intake seems to resonate and amplify my roller rockers typewriter sound and the valve tap against my iron heads WAY more extremely than I expected. Anyone else have this issue??
decipha
Posts: 714
Joined: 15 Feb 2021, 12:23
Location: New Orleans, LA
Vehicle Information: 10x Supercoupes
Lincoln LS 5spd
Ls1 t56 ss camaro
Whippled Harley Truck
gmc 2500hd classic
gt40p explorer
Marauder
Chrysler 300 AWD hemi
3.5 Explorer

Re: Gt40 tubular - just loud?

Unread post by decipha »

Any more progress with her?

May just be the nature of the beast
Landho
Posts: 14
Joined: 27 Feb 2021, 16:19
Location: Austin, TX USA
Vehicle Information: 1969 Ford Bronco
347 Stroker, Dart Heads, CBAZA

Re: Gt40 tubular - just loud?

Unread post by Landho »

I got the intake whistle to go away - it was the ACT in the gt40 upper - swapped it with the newer “plastic” ACT and clocked it, plus I honed the IAC ports a bit more smoother - no more intake whistle.. then learned the hard way my “new to me lower” intake had a problem, leaked coolant into #8... I thought it was drive belt or a pulley squeal so I drove it home, drove it again the next day - nope, when it was sitting I guess coolant was draining into #8 - hydrolocked cylinder #8, bent rod pretty sure and bearing squeeling (it still ran perfectly fine until hot, then it squeezed feirce) ... drained the new oil and it was shiny with metal - so pulling engine and taking it to machine shop to hot bath, replace rod, rings and bearings and whatever else it needs. Machine shops near me are all 2 month wait - so I’ve been shopping for a crate, but they’re all 2 month wait as well... even considered going modular but $12k+ isn’t in my budget right now ... looked at a decent 393 today but honestly this 347 is perfect size & setup for what I do, anything bigger would be more than my kids can drive also (they can barely drive this as it was)...

So - maybe in a month or two I’ll be back with a fresh rebuilt - considering going 700r4 auto as well - found a built one local and I am very tempted (I’m getting old and the 4-speed np435 and center force clutch don’t do my back injury much good anyways)
Post Reply