surging problem

Used on mid 90s mass-air broncos and F-Series trucks. SMD-221 Hardware.
Cal Codes: HOG0, HOG1, TIP1, VEX1, WAY1
GoldCO
Posts: 3
Joined: 30 Mar 2021, 17:24
Location: Golden, CO
Vehicle Information: '52 Ford F3 "rustomod" -- running fresh '95 5.8 (bored .030, flat-tops) with E4OD from '95 Lightning.

surging problem

Unread post by GoldCO »

hey folks, someone over at FTE forum suggested you guys might be able to answer my question…

running a 5.8 in my '52 F3 — donor motor (rebuilt), harness, PCM came from a '95 F150. the original PCM had the "leaky capacitor" issue, but I was able to find another from a local junkyard. truck ran perfectly fine for 18 months or so, then started "bucking" — let off the throttle and RPMs would surge 3x before settling. also had a couple of instances where it seemed the TC would remain locked up when I came to a stop. :o

just ordered a remanufactured PCM from "autozone": BSE Remanufactured Engine Control Computer ECC2517 (OEM #F5TF-YB). installed it, and thought it had solved the problem on the initial test drive, but then the next day the surging returned, though not as severe. popped the PCM open, and you can see where there they replaced that same capacitor (IC pretty scratched up).

my question is: any chance this reman unit may be bad, or, should I be looking at something else causing this issue? as mentioned, truck ran flawlessly the first year and half.

thanks for any insight. 8-)
decipha
Posts: 714
Joined: 15 Feb 2021, 12:23
Location: New Orleans, LA
Vehicle Information: 10x Supercoupes
Lincoln LS 5spd
Ls1 t56 ss camaro
Whippled Harley Truck
gmc 2500hd classic
gt40p explorer
Marauder
Chrysler 300 AWD hemi
3.5 Explorer

Re: surging problem

Unread post by decipha »

sounds like a bad idle air control valve
GoldCO
Posts: 3
Joined: 30 Mar 2021, 17:24
Location: Golden, CO
Vehicle Information: '52 Ford F3 "rustomod" -- running fresh '95 5.8 (bored .030, flat-tops) with E4OD from '95 Lightning.

Re: surging problem

Unread post by GoldCO »

decipha wrote: 30 Mar 2021, 19:11 sounds like a bad idle air control valve
hmmm... hadn't thought of that. thanks for the tip!
GoldCO
Posts: 3
Joined: 30 Mar 2021, 17:24
Location: Golden, CO
Vehicle Information: '52 Ford F3 "rustomod" -- running fresh '95 5.8 (bored .030, flat-tops) with E4OD from '95 Lightning.

Re: surging problem

Unread post by GoldCO »

Thank you, decipha

Replaced the IAC valve and (knock on wood) no more surging.
Much appreciated!
8-)
decipha
Posts: 714
Joined: 15 Feb 2021, 12:23
Location: New Orleans, LA
Vehicle Information: 10x Supercoupes
Lincoln LS 5spd
Ls1 t56 ss camaro
Whippled Harley Truck
gmc 2500hd classic
gt40p explorer
Marauder
Chrysler 300 AWD hemi
3.5 Explorer

Re: surging problem

Unread post by decipha »

yeah np
Post Reply