EEC Dying or Quarterhorse???

Vehicle specific forum for tuning the Foxbody Chassis Mustangs utilizing decipha's GUFX Strategy

EEC Dying or Quarterhorse???

Unread postby cmlomax » Fri Aug 18, 2017 4:57 pm

Car's been running great for over a year; everything's been dialed in a no issues. Out of the blue I get a CEL about 15-30 seconds after startup and the rpm's shoot up to ~2k from the usual 800 rpm idle. Code scanner says ECT sensor too high/low, TPS too high/low, BAP too high/low, etc. When I datalog with I can see at startup my TPS is .84 and CT then will jump to 1.29v and PT then stay there, even if I goose the throttle. The ECT sits at 150 and the BAP stays around 26-27. Reloading my tune doesn't help (I had the battery issue a couple years ago, had that fixed by Moates). Is this a failing EEC or a failing QH? One failure I can understand but multiple ones I don't believe in coincidences.

Carson
cmlomax
General Poster
 
Posts: 16
Joined: Sat Jul 27, 2013 8:16 am
Location: Vail, AZ
Vehicle Information: 1990 Mustang GT stock bottom end
QH/BE, LMAF, AFM Powerpipe, Accufab 70mm TB, E-brock Performer intake, FMS 24lb injectors, E-brock Performer heads, Crane Cobra 1.7rr's, E303 cam, BBK shorties, BBK catted H-pipe, E-brock RPM mufflers w/ turndowns, T-5 trans, 3.55 gears

Re: EEC Dying or Quarterhorse???

Unread postby decipha » Fri Aug 18, 2017 5:18 pm

the qh only serves the tune, if it fails the tune goes corrupt, sounds like your tune is working perfectly

definitely an ecu or wiring problem, sounds like u lost 5v ref
User avatar
decipha
Tooner
 
Posts: 18493
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer

Re: EEC Dying or Quarterhorse???

Unread postby cmlomax » Fri Aug 18, 2017 7:02 pm

Thanks for the response decipha.

I spent some more time with it and I think it's something to do with my clutch pedal. I took a video:

https://www.youtube.com/watch?v=Muee1zY ... e=youtu.be


Whenever I push the clutch in the TPS, BAP, and IAC are "ok" but when it's out they "freeze". What could be connected to the clutch pedal that would affect that? There's just the clutch position switch and the cruise control disengage switch, right?
cmlomax
General Poster
 
Posts: 16
Joined: Sat Jul 27, 2013 8:16 am
Location: Vail, AZ
Vehicle Information: 1990 Mustang GT stock bottom end
QH/BE, LMAF, AFM Powerpipe, Accufab 70mm TB, E-brock Performer intake, FMS 24lb injectors, E-brock Performer heads, Crane Cobra 1.7rr's, E303 cam, BBK shorties, BBK catted H-pipe, E-brock RPM mufflers w/ turndowns, T-5 trans, 3.55 gears

Re: EEC Dying or Quarterhorse???

Unread postby jsa » Fri Aug 18, 2017 8:30 pm

Use a voltmeter to measure your 5v sensor feed with clutch in and out.
Cheers
John
jsa
Power Poster
 
Posts: 470
Joined: Thu Jan 16, 2014 1:44 am
Location: In the shed or On the Computer, 'straya
Name: John
Vehicle Information: Escort RS Cosworth
EEC-IV GHAJ0
ANTI, COSY, QUIK or CARD

Re: EEC Dying or Quarterhorse???

Unread postby cmlomax » Fri Aug 18, 2017 9:01 pm

jsa wrote:Use a voltmeter to measure your 5v sensor feed with clutch in and out.


Ok but how could the CSS do anything to the 5v signal? I'm not seeing a vref line that goes to the clutch pedal or am I missing something?
cmlomax
General Poster
 
Posts: 16
Joined: Sat Jul 27, 2013 8:16 am
Location: Vail, AZ
Vehicle Information: 1990 Mustang GT stock bottom end
QH/BE, LMAF, AFM Powerpipe, Accufab 70mm TB, E-brock Performer intake, FMS 24lb injectors, E-brock Performer heads, Crane Cobra 1.7rr's, E303 cam, BBK shorties, BBK catted H-pipe, E-brock RPM mufflers w/ turndowns, T-5 trans, 3.55 gears

Re: EEC Dying or Quarterhorse???

Unread postby jsa » Sat Aug 19, 2017 1:28 am

I've never seen Mustang wiring or diagram. The symptoms you described point to something going on with the sensor 5v feed.
Cheers
John
jsa
Power Poster
 
Posts: 470
Joined: Thu Jan 16, 2014 1:44 am
Location: In the shed or On the Computer, 'straya
Name: John
Vehicle Information: Escort RS Cosworth
EEC-IV GHAJ0
ANTI, COSY, QUIK or CARD


Return to Foxbody Tuning (GUFX)

Who is online

Users browsing this forum: No registered users and 3 guests