Page 3 of 3

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Mon Jun 25, 2018 7:45 am
by jhine5588
I got home Saturday after work and noticed the IPSIBR was reading around .150. I thought I had that dialed in already. I fixed that and drove it around a little yesterday and it seems much better. Going to do the same today and report back. I didn't change anything with the dashpot yet.



Jeremy

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Tue Jul 17, 2018 8:58 pm
by jhine5588
Still fighting trying to find why this thing is missing at WOT beyond 4,000. I'm going to replace the coil and ignition module and see what gives after that. Also I think I'm going to knock spark down about 4 degrees because it's commanding 30 above 4,000 and slowly increases to 32 up to 6500+ if the new parts don't help anything. This setup put 210 down on the old engine with only 22 degrees in it...

I got a good deal on a used C+L housing with a 42# sampling tube so that's in the car now as well. This unit doesn't have a screen. I need to find something that will work for me.



Jeremy

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Thu Jul 19, 2018 9:47 am
by jhine5588
Replaced both the ignition module and coil with Motorcraft stuff and no more skip! She will be going on the rollers soon. Hopefully within the week.



Jeremy

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Mon Aug 20, 2018 11:20 pm
by jhine5588
Put her on the rollers last week. 230/280 at 12:1 WOT. Gonna take her to the track next cause I'm sure I can pull some fuel out and see where she's happiest.



Jeremy

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Sun Sep 01, 2019 8:09 am
by jhine5588
A year later and she's still running well. Haven't made it to the track yet however. I ran into an issue this spring and all through summer where the car would randomly shut off... Tach drops to zero and done. Cycle the key and it would start every time!

I replaced the EEC with a reman one from ECUExchange.
I verified all of my wiring was good at the ignition switch.
Checked all of my grounds.
Replaced the distributor, cap and rotor.

Finally I began replacing parts that I had already replaced, starting with the coil... Same problem. Replaced the ignition module and no more problem!! Less than a year old and a Motorcraft module failed.

I'm still bothered with the lack of A/C idle control as well as the MFA not working as intended. I've been working on a tune based off the original A9L to maintain all of the stock features that the computer controlled. So far I've got it to the point it starts and drives down the road but once warmed up it surges rich and quits. I'm sure there's a multiplier I'm forgetting.

I really like the way Mike handles spark/fuel with load and %load and I'm trying to maintain that control feature on the factory tune. I haven't had much time to play with it however.



Jeremy

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Sun Sep 01, 2019 1:05 pm
by decipha
I have custom code in the a9l2 to turn the fan on with the ac

mfa is setup already as well in the a9l2 just simply need to enable it

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Sun Sep 01, 2019 1:23 pm
by jhine5588
I'm not using an electric fan, it's still a clutch fan. The issue I'm having is the car will stall when the a/c is on and I come to a stop, which it doesn't do when it's not on.

I tried turning on MFA and it didn't seem to work.


Jeremy

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Sun Sep 01, 2019 3:19 pm
by decipha
simple fix.. you need to dial in the ac idle air ppm scalar

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Wed Oct 14, 2020 5:03 pm
by jhine5588
Got to the track a few times this year. I was able to pull timing and fuel and run a best ET of 14.11@96.

60' is slow at 1.96 but that's me mostly I feel. I swapped out for 3.55 gears earlier this year as well and bumped back down to a 245/50R16 Nitto versus the 255/60R16 Mickey Street ETs I had.

I still have a few little things to play with on the tune but it's a wicked fun car to drive... Just needs a bit more up top in terms of power!



Jeremy

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Wed Oct 14, 2020 7:05 pm
by decipha
thats not bad at all

slap a set of heads on there and skip the 13s all together

Re: A9L2 tune progress- 89 roller w/ bolt ons looking for ad

Unread postPosted: Thu Oct 15, 2020 6:27 pm
by jhine5588
Yeah yeah yeah...

The cost of a set of heads I could build a turbo kit haha



Jeremy