tune Issue - going lean at any throttle

Tuning specific forum for all of Ford European and Australian specific tuning

tune Issue - going lean at any throttle

Unread postby FAT245 » Sun Mar 09, 2014 7:31 am

Hey Mike and others,

I am having issues with getting the car up and running again.
I recently upgraded to a PMAS MAF and F302 injectors.

Car takes a while to start, need to press throttle to get her to idle then once she is idling, any sort of Throttle involvement will result in hesitation and the engine refuses to rev up. If I can get her to rev lambda peaks at 1.55

It is almost like it is not registering that the throttle is moving?
It is really frustrating as there have been nothing but issues with this motor and tune and I am almost ready to give up and just get an SCT tune so if something goes wrong I can just point the finger and blame someone else.

I have checked base Fuel Pressure and it is at 39-40 psi. Using the injector template from this site.

any help is appreciated,

Engine Specs:

342 Windsor
AFR 185 Competition heads 58cc
Static compression of 10.7:1
Camshaft is .568/.570 238/242 LSA 109.5
Walbro GSS 340 Fuel Pump
Trick flow BOX-R Manifold
75mm TB
PMAS 3.5" Slot MAF


Cheers Nathan
FAT245
General Poster
 
Posts: 10
Joined: Tue Nov 19, 2013 6:30 am
Name: Nathan
Vehicle Information: AU Fairlane
342 Windsor | Custom Cam | AFR185 Heads | DiFillipo Pipes | Dual 3" to Diff Dual 2.5 from Diff

Re: tune Issue - going lean at any throttle

Unread postby decipha » Sun Mar 09, 2014 10:59 am

not surprised at all the ford 42lb injectors only flow 34.5 lbs/hr

If you know its lean then add fuel, drop your slopes to 38 and see if it helps
User avatar
decipha
Tooner
 
Posts: 15709
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Ponthieux
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce

Re: tune Issue - going lean at any throttle

Unread postby FAT245 » Sun Jun 15, 2014 5:34 pm

Sorry, This thread has been solved decipha,

The Pigtail i got with the PMAS Sensor, one of the pins came out.
Once this was fixed she drove fine!
FAT245
General Poster
 
Posts: 10
Joined: Tue Nov 19, 2013 6:30 am
Name: Nathan
Vehicle Information: AU Fairlane
342 Windsor | Custom Cam | AFR185 Heads | DiFillipo Pipes | Dual 3" to Diff Dual 2.5 from Diff


Return to Ford Euro & Aussie Tuning

Who is online

Users browsing this forum: No registered users and 1 guest

cron