Did I Just Wreck my MAF?

Non-specific forum for discussing hardware issues such as wideband faults, MAF, Injectors, etc..

Did I Just Wreck my MAF?

Unread postby Ghiaed1994 » Wed Sep 18, 2019 3:48 am

Hey All,

I have recently installed a 90mm Lighting MAF into my Falcon and used the following Diagram:
http://www.efidynotuning.com/pics/maf/4to5.gif

The only issue is i messed up Pins C and D - so it went A B D C.

Question is - did i wreck my MAF? My Datalogger still shows voltage on the MAF but by car will only start with the MAF Disconnected (i updated the MAF Transfer curve to suit).

Any feedback is much appreciated.

Thanks,
Nathan
Ghiaed1994
General Poster
 
Posts: 7
Joined: Wed Sep 18, 2019 3:42 am
Name: Nathan Roy
Vehicle Information: 1994 Ford Fairmont Ghia - Supercharged 5.0L

Re: Did I Just Wreck my MAF?

Unread postby decipha » Wed Sep 18, 2019 8:58 am

no it should be fine

make sure when cranking that your imaf counts are reading in the log

usually you just need to increase the maf down low if it starts sputters and dies
User avatar
decipha
Tooner
 
Posts: 20411
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Other Vehicle(s): Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer
06 Chrysler 300 AWD - Sharifa

Re: Did I Just Wreck my MAF?

Unread postby Ghiaed1994 » Thu Sep 19, 2019 8:35 pm

Decipha,

Thank you for your response, i feel a lot better!

When i get home i will try and increase the lower end of the MAF Curve, I am currently using:

90mm Ford Lightning / 03-04 Cobra
Voltage Flow
16.00 1686.63
5.000 1686.63
4.839 1485.72
4.679 1342.28
4.518 1220.06
4.358 1104.82
4.198 993.50
4.037 887.583
3.877 789.320
3.717 700.066
3.556 619.84
3.396 547.64
3.236 481.96
3.075 421.43
2.915 365.14
2.755 312.87
2.594 264.95
2.434 222.05
2.274 184.78
2.113 153.36
1.953 127.42
1.793 106.00
1.632 87.71
1.472 71.25
1.312 55.85
1.151 41.76
0.991 30.16
0.831 22.19
0.670 16.37
0.000 5.50

The Car Cranks but will not idle unless i apply some throttle. Even then the revs fluctuate, remove my foot from the pedal and then the car will die. Disconnect the MAF, starts first go an idles well.

I did go from 6psi to 9psi on the supercharger - but i would have imagined the increase flow on the supercharger would have been captured by the MAF? Or because the MAF is pre supercharger potentially the MAF is reading less and as you described increasing it will cater for this?

Thanks,
Nathan
Ghiaed1994
General Poster
 
Posts: 7
Joined: Wed Sep 18, 2019 3:42 am
Name: Nathan Roy
Vehicle Information: 1994 Ford Fairmont Ghia - Supercharged 5.0L

Re: Did I Just Wreck my MAF?

Unread postby decipha » Fri Sep 20, 2019 5:30 am

no if all was fine before then it should be the same now

if you changed the maf though then you have to start all over dialed in the maf
User avatar
decipha
Tooner
 
Posts: 20411
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Other Vehicle(s): Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer
06 Chrysler 300 AWD - Sharifa


Return to General Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron