Page 1 of 1

Help with zxa5 and auto

Unread postPosted: Tue Dec 04, 2018 9:25 pm
by timiacobucci
Hi, my name is Tim Iacobucci. I have a decent running modified stock tune for the mods listed in my signiture. I have been trying to either modifiy the zxa5 bin to work with my auto and/or implement the decipha recommended settings in my stock tune to work akin to zxa5. Both unsuccessfully and for different reasons. The engine runs very well using the zxa5 base but the transmission acts a bit crazy even with all the transmission related parameters available in the sailorbob def being identical between my modified stock tune and the auto modded zxa5. It acts like the TCC is cycling rapidly at higher load and it really doesn't want to downshift even though I have the shift curves super downshift happy and it is does downshift very readily on the modded stock tune.

Image
Image

BCSDC stays constant, what else should I be looking at in the log to see what the tcc is doing other than SPD_RATIO? I'm guessing at this point there must be other parameters which affect the transmission function that are not defined in the sailorbob definition.

Here is a link to that log, I can't attach .csv files here, how do you usually share logs here?
https://datazap.me/u/timiacobucci/log-1543978113-0?log=0&data=18-20-100-114&solo=100&zoom=3011-3287&mark=3155

On the flip side when I followed the write up on changing prldsw to 0 and copied most of the relevant information over from zxa5 into my stock bin I obviously am missing something because the ignition timing is negative most of the time.
Image

And here is how the working prldsw 1 modified stock tune looks

Image

And lastly in BE prldsw is listed by description not number value

Image

So, load/peak load =0, load =1, inferred load % =2?

I've attached the 3 relative tunes and I have logs I could share for each as well.

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 10:01 am
by decipha
I can't open them files

this should give you a much better start. you should be able to open this with BE

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 11:10 am
by timiacobucci
Thanks I'll try it out. Is there an error opening them?

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 4:23 pm
by decipha
yes something about null filler

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 7:34 pm
by timiacobucci
Something is wrong trying to use that tune. I put all of my critical info in and the fuel pump runs constant at key on power off. Could it be a BE version conflict? I'm running BE version 5.145 and sailorbob cdan4 def Revision: 5j if it matters.

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 7:45 pm
by decipha
write it without changing anything amd see if it acts normal

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 8:09 pm
by timiacobucci
I just tried it with no changes and the results were exactly the same. Fuel pump constantly on, no attempt to start.

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 8:38 pm
by decipha
i must have goofed something ill check over it when i get a chance

Re: Help with zxa5 and auto

Unread postPosted: Wed Dec 05, 2018 9:13 pm
by timiacobucci
Cool, thank you for the help.

Re: Help with zxa5 and auto

Unread postPosted: Thu Dec 06, 2018 9:09 pm
by timiacobucci
I transferred all of the spark related information from the bin you shared into my current working modified stock tune and it works. First time proper running with prldsw=0 and decent timing in it. Feels like a very different car and that was at about 18-19* of timing at WOT. Lambse is pretty close to wideband , still targeting low mid 11's to. I imagine short of detonation leaning it a bit more and a bit more timing can improve things still.

Re: Help with zxa5 and auto

Unread postPosted: Fri Dec 07, 2018 7:45 pm
by decipha
cool glad to hear your making progress I have not had an free time

Re: Help with zxa5 and auto

Unread postPosted: Sat Dec 08, 2018 12:56 am
by timiacobucci
I'm mainly following your write ups and looking at how you have things setup in the tunes you have shared so my progress with this is based on your work and contribution on this website so thank you again for everything here.

Is there a way to see in the logs if and what is modifying lambse and ignition timing in open loop? The spark source is borderline table but the values open loop are actually higher than what it should be at the load point it is on the map. Ie, load is 95 between a cell of 23 at 90 and 17 at 110 but the timing is 26, how and why is that happening?

Then at the same load point in the log lambse 1 and 2 are 11.2 and everything near that point on the base fuel table is 12.8.

Re: Help with zxa5 and auto

Unread postPosted: Sat Dec 08, 2018 1:19 am
by timiacobucci
I think I already figured out the fueling part was the WOT fuel multiplier. I changed those to the values in the tune you posted above. I am still wondering if there is a specific way to know exactly what multipliers are in affect at a certain time though.

Re: Help with zxa5 and auto

Unread postPosted: Mon Dec 10, 2018 6:37 pm
by decipha
just simplify it all and you'll get exactly what your commanding, if not you missed a modifier somewhere