STFT not dropping fast enough after CL

Non-vehicle specific forum for tuning all ford ecu's 1994-2004, including the 1994-1995 Mustang, 93-98 Mark VIII, 99+ F-150, 99-04 Mustang, 03-04 Cobra, 99-03 Harley Davidson and Lightning F-150

FBFG2, CBAZA, CZAJL, and all EEC-V

STFT not dropping fast enough after CL

Unread postby lowranger96 » Fri Nov 06, 2015 6:20 am

I'm remote tuning a couple of different 2.3/2.5 turbo rangers, both running 98-99 ranger ecu's. (FLH2 and GAJ1).

On both trucks I'm having an issue that I don't think I've seen before. When transitioning into boost in forced OL the stft drops correctly and exactly when it should, following the base fuel table. However, when in CL and transitioning into OL the stft drops slower and takes longer to get down to the wot fueling set in the fuel table.

To clarify:

transitions into boost at 60% load in the tune and fuel table is set to .80. When in open loop, at soon as the engine hits 60% load the fuel is right where I want it via the table.

When CL is controlling the fuel (ECTvs Load function set at 45%) the engine will transition into OL without a lean spike, however the commanded fuel is still .90-.85 when loads are in the 60-80% range and eventually gets down to .80.

I'm not sure why it's taking it so long for the commanded fuel to drop when CL is used.
1996 - 2.5 CP Flattops, Billet Crower 5.2 rods, Stock head bolts, Felpro 1035, Turbo VC, P&P BV Head, 2277 Cam/spring, Custom Log/Tial MVS, HE351, FMIC, FLH2, ID1000s, HPX Blowthrough, Binary Editor, E85
lowranger96
Power Poster
 
Posts: 273
Joined: Sat Jan 11, 2014 9:34 pm
Name: Chris Salmon
Vehicle Information: 96 ranger 2.3 turbo

Re: STFT not dropping fast enough after CL

Unread postby decipha » Sat Dec 05, 2015 3:08 pm

I just seen this dont know how i missed it

In any case when transitioning from CL to OL the OL Ramp Rate Delay scalar is used, usually it has a stupid low value like .02 which decrements lambse by .02 lambse per loop which takes forever

I recommend setting it to 1.0 and it will jump right down
User avatar
decipha
Tooner
 
Posts: 14022
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Ponthieux
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce

Re: STFT not dropping fast enough after CL

Unread postby lowranger96 » Wed Feb 03, 2016 10:23 am

thanks for the response I just saw that you responded LOL. Both those trucks I was working away developed issues and were parked to fix/winter. I'll have to take a look at their tunes to see what that ramp rate is set to and hopefully that clears up the issue.
1996 - 2.5 CP Flattops, Billet Crower 5.2 rods, Stock head bolts, Felpro 1035, Turbo VC, P&P BV Head, 2277 Cam/spring, Custom Log/Tial MVS, HE351, FMIC, FLH2, ID1000s, HPX Blowthrough, Binary Editor, E85
lowranger96
Power Poster
 
Posts: 273
Joined: Sat Jan 11, 2014 9:34 pm
Name: Chris Salmon
Vehicle Information: 96 ranger 2.3 turbo

Re: STFT not dropping fast enough after CL

Unread postby decipha » Wed Feb 03, 2016 12:14 pm

yea thatll fix it no worries

what are you using to tune ?
User avatar
decipha
Tooner
 
Posts: 14022
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Ponthieux
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce

Re: STFT not dropping fast enough after CL

Unread postby lowranger96 » Wed Feb 03, 2016 12:32 pm

I use BE to tune my truck, but all these other guys I use SCT on their end and remotely connect to them. FLH2 and GAJ1 ecu codes. Main reason for this is because BE doesn't have datalog support for the ranger def (at least they didn't when i bought mine) and it doesnt make much sense for the ranger guys to use BE if I'm tuning it because they will still need a datalogging device). On my rig, I can't stand using sct to make small changes because reflashing for every change is annoying...

That and I like the flip switch ability when the temps get colder and e85 becomes e70
1996 - 2.5 CP Flattops, Billet Crower 5.2 rods, Stock head bolts, Felpro 1035, Turbo VC, P&P BV Head, 2277 Cam/spring, Custom Log/Tial MVS, HE351, FMIC, FLH2, ID1000s, HPX Blowthrough, Binary Editor, E85
lowranger96
Power Poster
 
Posts: 273
Joined: Sat Jan 11, 2014 9:34 pm
Name: Chris Salmon
Vehicle Information: 96 ranger 2.3 turbo

Re: STFT not dropping fast enough after CL

Unread postby lowranger96 » Wed Feb 03, 2016 9:34 pm

I looked in both BE and SCT and didn't find a scalar such as this
1996 - 2.5 CP Flattops, Billet Crower 5.2 rods, Stock head bolts, Felpro 1035, Turbo VC, P&P BV Head, 2277 Cam/spring, Custom Log/Tial MVS, HE351, FMIC, FLH2, ID1000s, HPX Blowthrough, Binary Editor, E85
lowranger96
Power Poster
 
Posts: 273
Joined: Sat Jan 11, 2014 9:34 pm
Name: Chris Salmon
Vehicle Information: 96 ranger 2.3 turbo

Re: STFT not dropping fast enough after CL

Unread postby decipha » Wed Feb 03, 2016 9:47 pm

its there you just may not have access to it
User avatar
decipha
Tooner
 
Posts: 14022
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Ponthieux
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce

Re: STFT not dropping fast enough after CL

Unread postby lowranger96 » Thu Feb 04, 2016 6:34 am

Weird.. I'll have to ask Adam. Sucks I can't find it in sct because I have more issues with those guy's trucks than mine
1996 - 2.5 CP Flattops, Billet Crower 5.2 rods, Stock head bolts, Felpro 1035, Turbo VC, P&P BV Head, 2277 Cam/spring, Custom Log/Tial MVS, HE351, FMIC, FLH2, ID1000s, HPX Blowthrough, Binary Editor, E85
lowranger96
Power Poster
 
Posts: 273
Joined: Sat Jan 11, 2014 9:34 pm
Name: Chris Salmon
Vehicle Information: 96 ranger 2.3 turbo

Re: STFT not dropping fast enough after CL

Unread postby lowranger96 » Sun Dec 10, 2017 4:20 pm

bringing some closure to this. I fellow 2.3 guy finally found the function causing this issue and it was right under my nose the entire time. On the truck ecus there is an open loop enleanment function for fuel economy. This function is set from 0-3 sec to apply a 1 - 1.2 afr multiplier. this had been screwing me up for a long time on these trucks because anytime you went from closed to open loop it would command lean for a sec then drop. So if anyone is having this issue check this function out (most likely only on truck ecus according to the notes sct gives in their software).
1996 - 2.5 CP Flattops, Billet Crower 5.2 rods, Stock head bolts, Felpro 1035, Turbo VC, P&P BV Head, 2277 Cam/spring, Custom Log/Tial MVS, HE351, FMIC, FLH2, ID1000s, HPX Blowthrough, Binary Editor, E85
lowranger96
Power Poster
 
Posts: 273
Joined: Sat Jan 11, 2014 9:34 pm
Name: Chris Salmon
Vehicle Information: 96 ranger 2.3 turbo

Re: STFT not dropping fast enough after CL

Unread postby motorhead1991 » Sun Dec 10, 2017 4:59 pm

BE mentions heavy duty and fuel economy as well. I can also confirm that this works. I've had a problem with a strange backfire under load, which seems to have gone away after correcting this function.
motorhead1991
Power Poster
 
Posts: 111
Joined: Mon Apr 03, 2017 6:46 pm
Name: Anthony Cox
Vehicle Information: 1990 Ford Ranger FLH2 conversion. Ford forged/dished pistons, Total Seal file-fit rings, Clevite rod and main bearings, Clevite cam bearings, IHI turbo, Siemens Deka 60lb/hr injectors, Ford slot MAF in custom 3" housing. Moates Quarterhorse with Binary Editor, using the PAAD6 database.
Vehicle 2 Information: Stock 1990 Ranger. ICM relocation


Return to EEC-V & SN95 Tuning

Who is online

Users browsing this forum: No registered users and 15 guests