X3Z Review 1993 Cobra

subforum for requesting current tune review services
Not happy with your current tune? Or if you just want
a 2nd opinion, this is the place for it

X3Z Review 1993 Cobra

Unread postby 1993cobro » Sun May 08, 2016 8:49 pm

Nothing pops out as issues with the way it runs just curious as to anything i need to make changes to or improve upon. 1993 Cobra, X3Z binary editor and quarterhorse. Mods are ported heads (bowls, termactor bumps and valve pockets milled .030) and lower intake porting, longtube headers, stock camshaft, upgraded valve springs, cold air intake. Stock 24lb injectors and 70MM maf. Only issue that jumps out at me is my whistling throttle body which i may have got a little happy on porting. Thanks in advice
You do not have the required permissions to view the files attached to this post.
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor

Re: X3Z Review 1993 Cobra

Unread postby decipha » Fri Jun 17, 2016 10:04 am

its basically a stock 93 cobra tune

your maf is clipped at 4.454 volts same as a stock cobra tune, thats horrible henry should never have done that from the get go

instead of going in there and modifying the maf transfer you should drop the stoich from gas to e10 that should get your fuel pretty close

if you look on the homepage under reference there's a stock simplified curve for the 93 cobra 70mm / supercoupe maf, I HIGHLY RECOMMEND loading that in, dropping the stoich AFR and adjusting the maf as needed from that point on

your spark control isn't too well either, you might want to consider using the A9L2 to make everything easier
User avatar
decipha
Tooner
 
Posts: 19120
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer
06 Chrysler 300 AWD

Re: X3Z Review 1993 Cobra

Unread postby 1993cobro » Sun Jul 03, 2016 6:56 pm

Thanks Decipa, made the changes suggested and will be trying soon as the car is from the body shop and done putting the comp xe270hr camshaft in :mrgreen:
Heres what i done using the A9l2 as a base
You do not have the required permissions to view the files attached to this post.
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor

Re: X3Z Review 1993 Cobra

Unread postby decipha » Tue Jul 05, 2016 7:53 am

you didn't put in your injector info
you corrupted the maf transfer
you dropped the injector timing?
you didn't correctly adjust the cranking pw
you didn't apply your mbt offset to the spark table

here you go, this will give you an excellent base to start tuning from

this will only work with the latest gufb.xdf for tunerpro on the homepage
You do not have the required permissions to view the files attached to this post.
User avatar
decipha
Tooner
 
Posts: 19120
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer
06 Chrysler 300 AWD

Re: X3Z Review 1993 Cobra

Unread postby 1993cobro » Mon Jul 11, 2016 7:38 pm

Got that base tune in and it seems to run well now especially for a base! Only issue im having is getting it to go into closed loop seems to stay open so once thats figured out time to dial in the MAF
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor

Re: X3Z Review 1993 Cobra

Unread postby decipha » Mon Jul 11, 2016 8:38 pm

usually if it doesn't jump into closed loop either the fuel is too far out (doubtful) or the hegos aren't functioning correctly
User avatar
decipha
Tooner
 
Posts: 19120
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer
06 Chrysler 300 AWD

Re: X3Z Review 1993 Cobra

Unread postby 1993cobro » Mon Jul 11, 2016 8:49 pm

Yeah im thinking thats what it is, car has brand new ntk o2 sensors in it also
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor

Re: X3Z Review 1993 Cobra

Unread postby decipha » Mon Jul 11, 2016 10:27 pm

make sure the hego ground wire is attached at the back of the head, if it isn't then you'll need to ground the hego reference ground pin at the ecu
User avatar
decipha
Tooner
 
Posts: 19120
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer
06 Chrysler 300 AWD

Re: X3Z Review 1993 Cobra

Unread postby 1993cobro » Tue Jul 12, 2016 2:25 pm

Checked the ground and all is well there, I did find logging it when just giving the throttle a quick blimp it will flash in and out of Closed loop though. I haven't had much time to mess with it but will try it again tonight and try to get the wideband in
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor

Re: X3Z Review 1993 Cobra

Unread postby decipha » Tue Jul 12, 2016 4:08 pm

how do u know its flashing in and out of closed loop ? Thats very odd that it would do that, chances are niold or lolod would be preventing closed loop in that case
User avatar
decipha
Tooner
 
Posts: 19120
Joined: Mon Jul 15, 2013 5:29 pm
Location: New Orleans, LA
Name: Michael Decipha Ponto
Vehicle Information: Supercoupin' x10
90 (4x 5spds) - Dante, Ruby, Daja, Ava
91 4r70w - Skarlett
92 (2x) 5spd & auto - Bianqa, Andrea
93 auto - Danika
94 5spd Rionda
95 auto Aisha
Vehicle 2 Information: Others:
00 Lincoln LS - Luanda
98 Camaro SS - Bounquisha
02 Harley F-150 - Sasasha
03 Marauder - DyShyKy
00 Explorer 5L - Bernyce
07 GMC 2500HD 6L - Veranafer
06 Chrysler 300 AWD

Re: X3Z Review 1993 Cobra

Unread postby 1993cobro » Tue Jul 12, 2016 4:44 pm

Could have sworn i saw the small indicator on the logging screen show CL a couple times, but in the last couple logs ive tried it never happened :oops:
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor

Re: X3Z Review 1993 Cobra

Unread postby 1993cobro » Thu Jul 14, 2016 4:05 pm

Done some experimenting on the closed loop issue. Put the stock X3Z calibration in and it went into closed loop :?:
No clue what is causing it to stay open loop on the A9L2 tune, got some research to do now!
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor

Re: X3Z Review 1993 Cobra

Unread postby 1993cobro » Sat Jul 16, 2016 12:26 pm

Played a little more with it today, swapped out the ntk o2 sensors i had put in a couple thousand miles ago to some new ones and it seems to stay in closed loop even in the a9l2 calibration and seems to run pretty good. Still have to get the 02 bung welded in for the wideband now have to find a way to get my kamrf's to reset as they are just staying at 1. I must say it idles and drives well with the a9l2!
1993cobro
General Poster
 
Posts: 8
Joined: Sun May 08, 2016 8:32 pm
Name: Jamie
Vehicle Information: 1993 Mustang Cobra, X3Z Quarterhorse/Binary Editor


Return to <<--Tune Review-->>

Who is online

Users browsing this forum: No registered users and 1 guest

cron